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Rainfall Runoff Modelling Using NRCS-CN Method 
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Problem: You have to estimate surface runoff using NRCS-CN method for Ajmer Area. You 

have been provided with DEM, Soil map, LULC map, Rainfall map and watershed map.  

Curve Number Method for Runoff Generation 

The Stream flow which is measured in a river consists of 3 components namely the surface runoff, 

sub-surface and ground water (base flow) components Fig 1.  Mathematically it is possible to 

quantify these components individually.  But remote sensing and GIS play a prominent role in 

quantifying only the surface runoff.  Runoff is computed indirectly using the soil type, land cover, 

and its hydrologic condition, in a model, of course with rainfall data also. The Natural Resources 

Conservation Service Curve Number (NRCS-CN) formerly known as Soil Conservation Service Curve 

Number (SCS-CN) method, developed by the USDA-Soil Conservation Service (SCS, 1972), is widely 

used for the estimation of direct runoff for a given rainfall event from small agricultural watersheds 

as it takes into account most of the watershed’s runoff producing characteristics such as soil type, 

landuse, hydrologic condition and antecedent moisture condition. The thematic maps 

corresponding to each parameter may be generated and stored in the common spatial geo-

database created in a GIS with the help of remote sensing data.  

Natural Resources Conservation Service Curve Number (NRCS-CN) method is an experimentally 

derived method to determine rainfall excess using information about soils, vegetative cover, 

hydrologic condition and antecedent moisture conditions . 

The NRCS-CN method is based on a water balance and two fundamental hypotheses which can be 

expressed, respectively, as follows (SCS, 1972): 

QFIaP       (1) 

where, P  is the precipitation (mm), Ia is the initial abstraction (mm), F  is the cumulative infiltration 

excluding Ia, Q is the direct runoff (mm).  

 

Let Ia be the initial quantity of interception, depression storage and infiltration that must be satisfied 

by any rainfall before runoff can occur.  It is based on the hypothesis that ration of runoff (Q) to 

maximum potential runoff (P-Ia) and cumulative infiltration (F) to maximum possible infiltration 

i.e., Retention ‘S’ is equal, as mentioned below-  

S

F

IaP

Q



      (2) 

Ia is assumed to be a fraction of S. 

SIa        (3) 
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S is the potential maximum retention after beginning of the runoff (mm) and λ is the initial 

abstraction ratio. Knowing P and S the value of Q can be calculated. Q has the same units of P. On 

combining (1), (2) and (3), it gives an expression for Q: 

 
IaSP

IaP
Q






2

        (4) 

Eq. (4) is valid for P > Ia, otherwise, Q = 0. The parameter S in Eq. (4) is defined as 

254
25400


CN

S      (5) 

where, CN is the runoff curve number of hydrologic soil cover, which is a function of soil type, land 

cover and varies with one of three antecedent soil moisture conditions (AMC): AMC-I, AMC-II and 

AMC-III. Fig. 1 shows flow chart for NRSC-CN methodology adopting remotes sensing data 

integrated with GIS. 

 

Fig. 1: Flow Chart Runoff Estimation Using NRCS-CN Integrating RS and GIS 
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In practice, curve numbers are first calculated for AMC-II and then adjusted to AMC-I or AMC-III 

depending on the 5-day antecedent rainfall depth that depends on whether the crop is in the 

dormant or growing season as depicted in Table 1. The values of CN2 correspond to AMC-II for 

different landuse against different hydrologic condition of soil group can be found in SCS handbook 

(SCS, 1972) or standard hydrology textbooks and large number of literature. The values of CN 

range from 0 to 100. The sample table for CN2 values corresponds to fallow, row crops, forest, 

pasture and water body is given in Table 2. CN2  can be determined by 2 dimensional table or 

crossing LULC map and hydrological soil group map using cross function of GIS. The LULC map 

can easily be prepared from satellite data using classification technique based on extensive ground 

truth. Whereas the detailed soil map can be obtained from the ground truth or made by 

interpretation of physiographic units and field survey. The National Bureau of Soil Survey & Land 

Use Planning soil maps are also available with hydrological soil group identified for each soil type 

for every state.  

Table 1: AMC for Determining the Value of CN 

AMC class 

5-day antecedent rainfall (cm) 

Non-monsoon 

period 
Monsoon period 

I. Optimum soil condition from plastic limit to wilting 

point 
Less than 1.25 Less than 3.5 

II. Average value for annual floods 1.25 to 2.75 3.5 to 5.25 

III. Heavy rainfall or low rainfall and low 

temperature during five days preceding the storm 
Over 2.75 Over 5.25 

        (Source:- Chow, 1988) 

Table 2: Curve Number Table 

Land Use/HSG A B C D 

Fallow 77 86 91 94 

Row crops 67 78 85 89 

Forest  45 66 77 83 

Pasture 49 69 79 84 

Water body  100 100 100 100 

 

The daily rainfall data can be procured from any meteorological department, even, spatial rainfall 

products (like TRMM, CPC, Aphrodite data) of remote sensing data available freely on internet can 

be utilized. The point data procured from meteorological department can be interpolated using 

spatial interpolation tools available in GIS. The estimate average weighted rain in each watershed 

from interpolated rainfall data using zonal statistics tool of Arc GIS. Since the procedure of 
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estimating weighted average rainfall in all sub-watershed for all rainy days is repetitive work, so a 

customized model can be build in GIS environment.  

Initially, CN2 for each sub-watershed can be determined based on LULC, soil and hydrologic 

conditions using traditional NRCS-CN approach adopting corresponding values from Table 1 and 

Table 2. As, in the original NRCS-CN method the effect of slope has not been taken into account 

while calculating CN. Moreover, land slope parameter has been considered as an important factor 

in determining water movement (El-Hassanin et al., 1993; Barros et al., 1999; Ahmad, 2001; 

Haggard et al., 2002; Chaplot and Bissonnais, 2003; Huang et al., 2006).  To overcome the problem 

of slope, Sharpley and Williams (1990), carried out some slope adjustment to CN2 calculation as 

follows: 

   2

86.13

232 21
3

1
CNeCNCNCN   

    (6) 

Where, CN  is slope adjusted CN2;  (m/m) is the slope. However, this approach has not been 

intensively verified in the field (Huang et al. 2006). Hence, Huang et al. (2006) adopted a simplified 

approach and proposed an equation for slope modified Curve Number (CN ) for slope gradient 

range from 0.14 to 1.4 as follows: 

 

 
52.323

63.1579.322
22









 CNCN    (7) 

CN2 and CN3   in above formulae are the CN for AMC-II and AMC-III respectively. Here alpha is 

slope in meter per meter. Hope and Schulze (1981) questioned these AMC approach and 

highlighted three weaknesses in it such as the relationship between AMC and antecedent rainfall 

holds for discrete classes, rather than continuous; the use of 5-day antecedent rainfall is not based 

on physical reality, but on subjective judgment; and evapotranspiration and drainage are not 

considered in depletion of catchment storage. To convert CN2 to CN1 & CN3; Sobhani (1975), 

Hawkins et al. (1985), Chow et al. (1988) and Neitsch et al. (2002); proposed mathematical 

expressions as presented in Table 3.  

Table 3 CN Conversion Formulae 

Method AMC – I AMC - III 

Sobhani 

(1975) 2
01334.0334.2

2
1 CN

CN
CN


  

2

2
3

005964.04036.0 CN

CN
CN


  

Hawkins 

et al. 

(1985) 
2

2
1

01281.0281.2 CN

CN
CN


  

2

2
3

00573.0427.0 CN

CN
CN


  

Chow et 

al. (1988) 2

2
1

058.010

2.4

CN

CN
CN


  

2

2
3

013.010

23

CN

CN
CN


  
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Neitsch 

et al. 

(2002) 

 
   22

2
21

1000636.0533.2exp100

10020

CNCN

CN
CNCN




    223 10000673.0exp CNCNCN   

       (Source:- Mishra et al., 2008) 

Mishra et al. (2008) compared these conversion formulae, as determining the CN is very sensitive 

to runoff calculation. It was suggested that the Sobhani (1975) formula is best for CN1 conversion 

whereas the Hawkins et al. (1985) for CN3 conversion. So, these conversion formulae can be used 

to calculate CN1 and CN3, respectively for the sub-watersheds falling in such categories. 

 

The representative mean values of CN2 and CN  for each sub-watersheds can be calculated using 

zonal attributes tool in Arc GIS. Similarly, the CN1 & CN3 for each sub-watershed can be obtained 

using above conversion formulae along with original NRCS-CN model table. Knowing the values of 

CN2 or CN , and their corresponding CN1 and CN3, the factor S (mm) has been determined for 

each sub-watershed accordingly. Then Ia has been estimated using the expression Eq. (3). Usually, 

λ has been assumed as 0.2 for a large number studies. Finally, the runoff depth in each sub-

watershed for each rain event can be calculated adopting the Eq. (4). 

Tutorial 

Find out the Hydrological Soil Group (HSG) for each pixel from the given soil map using following 

table. Open soil map in ArcGIS. You have been provided with DEM, Soil map, LULC map, 

Rainfall map and watershed boundary map.   

Open the given soil map (add layer f_soil_text.shp in the ArcMap) in ArcGIS, it will appears 

somewhat like this:  
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Now, to see its all soil texture classes, right click on f_soil_text.shp  layer in Table of content and 

go to properties, in Symbology tab, select value field, Categories and then select the Soil_text and 

click “Add All Values” and then click “ok”. We have selected soil texture classes for the display. 
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Soil Description of the Hydrologic Soil 
group Group 

A Lowest runoff potential. Includes deep 

 sand with very little clay and silt. 
B Moderately low runoff potential. 

 Mostly sandy soil less deeper than A 
C Moderately high runoff potential. 

 Comprises  shallow  soil  of  clay, colloids 
D Highest  runoff potential. Includes mostly 

clay of high swelling percent, nearly 
impermeable soils. 

 

 

 

Now, open attribute table of soil map, you will find soil type correspond to each polygon 

for entire watershed. 

SOIL_TEXT HSG 

Loamy Sand A 

Loamy Skeletal B 

Sand A 

Sandy Loam A 

Silt Loam C 
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Now we will assign Hydrological Soil Group category based on soil texture class. 

A new column will be added in the attribute table of Then go to Table Options and click on “Add 

Field” give Name as “HSG” and Type as “text” . Length you can give “5” as its just single letter (A, 

B, C, D). Then click “ok”.  
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In given file we have created the HSG column for you. 

You will find HSG column has been added to your attribute table. Now, to assign 

corresponding HSG following steps has to be performed: Go again to Options at the bottom 

of the window, click “Select by attribute”. 
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Now, double click on Soil_Text -> click = -> Get Unique Values -> double click “Loamy 

sand” -> Apply. It will select all polygons of “Loamy sand” class. 
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Then go to HSG column, right click and then click on Field Calculator and then assign HSG 

= “B” and click ok. Follow same steps for other soil classes too and assign corresponding 

HSG group as mentioned table above. 
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Now we will calculate Curve Number (CN-II) corresponding to land use land cover and 

HSG Group.  

Find out the CN-II for each pixel with the help of HSG derived from soil map and LULC 

map with the help of table provided below. Open the given LULC map in ArcGIS.  

Here you have to use spatial Join tool to join attributes of both layers i.e., f_soil_text and 

lcover05. ArcGIS ToolBox -> Analysis Tools -> Overlay -> Spatial join. 
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After joining the two feature layers, a map will be generated with following attributes, now 

you see soil class and corresponding LULC, so one can derive CN_II map for the basin. 

 



17 
 

  

Then go to Options at the bottom of the Attribute of soil map window and click “Add Field” 

give Name as “CN_II” and Type as “Short Integer”. Precision you can give “0” as they are 

integer numbers. Then click “ok”. 
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You will find CN-II column has been added to your attribute table. Now, to assign corresponding 

CN_II values from table in this column. Go again to Options at the top of the window, click “Select 

by attribute”. Now, double click on "luse_class" -> = -> Get Unique Values -> 'Barren Land' -> 

AND -> double click "HSG" -> = 'A' -> Apply. It will select all polygons with “agriculture” LULC 

class and “A” HSG class. 

 

 

 Then go to CN-II column -> right click -> Field Calculator -> CN-II = “49” -> ok. 
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Follow same steps for other combinations too such as  

 

LULC_CLASS A B C D 

Barren Land' 49 69 79 84 

Dense Mix Vegetation 26 40 58 61 

Exposed Rocky Terrain 77 86 90 93 

Fallow Land 39 61 74 80 

Low Mix Vegetation 28 44 60 64 

Rocky Terrain 77 86 90 93 

Sandy Soil 25 44 55 60 

Settlement 89 92 94 95 

Shrub Land 49 68 79 84 

Water 100 100 100 100 

Wet Alluvium Soil 91 95 96 98 

 

“Barren Land'” lulc class and “A” HSG, CN_II “49”; 

“Dense Mix Vegetation” lulc class and “A” HSG, CN_II “26”;  

“Exposed Rocky Terrain” lulc class and “B” HSG, CN_II “86”; 

Now we will use the raster calculator for further calculations. 

Now, to prepare CN-II map by converting polygon map into raster map, go to ArcToolbox 

-> Conversion Tools -> To Raster -> Polygon to Raster 
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Input Feature will your spatially joined soil and LULC map, Value Field will be CN_II column, 

Output Raster Dataset will be your CN_II_Map. Make Sure the cell size should be same as 

DEM cell size, as we have to all analysis at DEM cell size. 

 

Then carry out slope correction in CN-II using Huang (2006) approach. Derive slope map 
from provided ASTER DEM using Spatial Analyst Tool.  
 
Go to ArcGIS Toolbox -> Spatial Analyst Tools -> Surface -> Slope 
Input Rater will be dem, Output Raster will be Slope and Output Measurements 
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(optional) will be PERCENT_RISE, then click “ok”. 

 

To convert slope percentage map in slope meter per meter, the slope percentage map 

should be divided by 100. For this operation use raster calculator. Using following equation. 

Go to Spatial Analyst Tools -> Map Algebra -> Raster Calculator 

 

Slope_mpm = "Slope_per" / 100 
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The original NRCS method has been developed for slope less than 5% but in your case 

slope may vary more than 5%. So to incorporate slope in calculation Huang (2006) 

proposed following equation for NRCS method: 

  

Same equation has been used in raster calculator for slope correction. 
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"CN_II_Map" *((322.79  + (15.63 * "Slope_mpm")) / ("Slope_mpm" + 

323.52)) 

 

Give output names as “CN_II_slp” 

  

 

Keep a check, the value of CN-II slope corrected should not exceed 100. If it is exceeding 

100, then open Raster Calculator again and put following 

Con("CN_II_slp" > 100,100,"CN_II_slp") 

Give output names as “CN_2” 

Further, as discussed above, depending upon the AMC condition (Antecedent Moisture 

Condition) which is to be calculated based on last five days precipitation, CN2 needs to be 

converted into CN_1 or CN_III 

To convert CN2 TO CN1 according to AMC condition use following condition in raster 

calculator. 

"CN_2" / (2.334 - 0.01334 * "CN_2")  

Give output names as “CN_I” 
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To convert CN2 TO CN3 Acc. To AMC condition 

"CN_2" / (0.427 + 0.00573 * "CN_2") 

Give output names as “CN_III” 

 

 

To find out actual CN according to AMC,  first of all add 5 raster data having preceding 05 

days precipitation. Click on Add data then go to data folder where your 05 days rainfall 

data set is available (rainfall). Select rainfall and click ok. Then to calculate Curve number 
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as per the AMC condition use raster calculator and put following condition in Raster 

calculator 

 

Con("rainfall" <= 35,"CN_I",(Con("rainfall" >= 52.5,"CN_III","CN_2"))) 

 

Give output names as “CN_actual 

Please refer NRSC method  of runoff estimation, now we need to calculate Maximum 

Potential Retention “S”. Again go to spatial analyst in ArcTool Box and click on map algebra 

and then Raster calculator. Then use the mathematic expression to compute S. 

S = (25400 / "CN_actual") – 254 

Give output names as “S_MAP” 

 

To calculate initial abstraction “I”, again go to Raster calculator and use following 

expression (condition) to calculate initial abstraction. 

I=0.2 * "S_MAP" 

Give output names as “I_MAP” 
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To calculate runoff depth “Q” 

Q will be estimated only when rainfall P > I that means whenever Initial abstraction is less 

than rainfall, then only runoff will occur. We will use event rainfall which is available as 

rainfall_aoi (one day rainfall) to calculate runoff. 

Con("rainfall_aoi" >= "I_MAP", Power(("rainfall_aoi" -"I_MAP"),2) / ("rainfall_aoi" + 

"S_MAP" - "I_MAP"),0) 

Give output names as “Q_MAP” 
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To Calculate runoff coefficient –Runoff coefficient is a ration of runoff and rainfall for 

a particular area. If we have runoff coefficient for any watershed then we can calculate 

runoff for any given rainfall event. Please go to again raster calculator use following 

expression to estimate runoff coefficient for above discussed watershed. 

 

"Q_MAP" / "rainfall_aoi" 

Give output name as runoff_coe and click ok. 

 

 

Further exercise to calculate runoff will be done in excel 

1. You have been given daily rainfall of ajmer , identify dormant and growing season 

(1 june to 31 October has been consider as a growing season) 

2. Calculate  
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